On 8/30/06, Damian Conway <[EMAIL PROTECTED]> wrote:
That's a little unfair. Choose good names and it's perfectly clear:

     map { "Element $^array_index is called $^array_value" } <== @array.kv;

As an aside, though, doesn't that particular solution now implicitly
rely on the fact that ('index' lt 'value')?

I get the feeling that if people want to give meaningful names to
their $^ parameters, they'll have to learn to start putting
predictable alphabetic prefixes in front of them.

Perhaps the lesson is that if you want something more descriptive than
$^a/$^b, you should be using a pointy block instead ...


Reply via email to