> +++ doc/trunk/design/syn/S03.pod      Fri Feb  2 01:07:36 2007
>      if $filename ~~ :e { say "exists" }
> +    if $filename.:e { say "exists" }
> +Both of these forms actually translate to
> +
> +    if $filename.TEST(:e) { say "exists" }

Hey, that looks good.

I've got a slight concern over the name C<TEST> though.  The Perl QA
folk already seem to have enough trouble coming up with enough
permutations of "test", "tests", "Test", "TEST", and so on for labelling
tests, test frameworks, and things that relate to testing.  Which this

(But I have't got a suggestion for a better name.)


Reply via email to