Larry Wall wrote:
Nevertheless, for any major methods borrowed from Perl 6, I'm not
inclined to change them that drastically. Much more likely to
define them as sugar for the more general list operators:
.push means .=append
.unshift means .=prepend
.splice means .=impend :-)
or some such.
I like those. I feel similar to Matt W. I kind of like .push and
.unshift the way they are (probably just habit) But I can appreciate
that non-mutating alternatives might open a new class of algorithms from
the functional world.