Author: TimToady <la...@wall.org>
Date: 2010-09-29 (Wed, 29 Sep 2010)
This change includes the addition of get_value() and set_value() routines.
I would argue that naming accessors get/set is a bad idea, "set" in particular,
because "set" would easily evoke thoughts of having something to do with "set"
collection types and values.
Instead, much better names for the updating accessor are either "update" or
"store" or "assign", and I personally prefer "update" between the three.
As for "get", that is less of a problem as it is, though it could alternately be
spelled either "fetch" or by leaving the prefix off; for an example of the
latter, the accessors could be named "value" and "update_value()".
But regardless of whatever else you do, "set" for this purpose has got to go.
-- Darren Duncan