tl;dr; - it worked, after a little fiddling w/ execstack on
(remove executable stack flag).

Just got the bash/linux extensions beta installed on win10 and so I tried
rakudo using:
$  sudo perl --gen-moar --prefix /mnt/opt/rakudo-star-2016.11

didn't think it would work but that goes along happily until:
/usr/bin/perl -MExtUtils::Command -e cp 3rdparty/dyncall/dynload/*.h
/usr/bin/perl -MExtUtils::Command -e cp 3rdparty/dyncall/dyncall/*.h
/usr/bin/perl -MExtUtils::Command -e cp 3rdparty/dyncall/dyncallback/*.h
Building NQP ...
/usr/bin/perl --prefix=/mnt/opt/rakudo-star-2016.11
--backends=moar --make-install

Creating tools/build/ ...
/mnt/opt/rakudo-star-2016.11/bin/moar: error while loading shared
libraries: cannot enable executable stack as shared object
requires: Invalid argument

No suitable MoarVM (moar executable) found using the --prefix
(You can get a MoarVM built automatically with --gen-moar.)

Command failed (status 32512): /usr/bin/perl
--prefix=/mnt/opt/rakudo-star-2016.11 -backends=moar --make-install

There is a /mnt/opt/rakudo/bin moar and a lib/ but running it
gets the same msg. Found:

and install execstack and running

$ sudo execstack -c /mnt/opt/rakudo-star-2016.11/lib/

gets moar to run and on to "make" which works though it finishes

NQP has been built and installed.
Using /mnt/opt/rakudo-star-2016.11/bin/nqp-m (version 2016.11 / MoarVM

Creating Makefile ...
Cleaning up ...

You can now use 'make' to build Rakudo.
After that, 'make test' will run some tests and
'make install' will install Rakudo.

and after make works, "make test" gets
andy@ANDY-HP:~/src/rakudo-star-2016.11$ make test

To run the Rakudo compiler tests, use 'make rakudo-test'
To run the Perl 6 spectests, use 'make rakudo-spectest'

To run the modules' test suites, run 'make modules-test'

spectest gives:
andy@ANDY-HP:~/src/rakudo-star-2016.11$ sudo make rakudo-spectest
cd rakudo && make spectest
make[1]: Entering directory `/home/andy/src/rakudo-star-2016.11/rakudo'
cd t/spec && git pull --ff-only
fatal: Not a git repository (or any parent up to mount point /home)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
make[1]: [spectest_update] Error 128 (ignored)
/usr/bin/perl t/harness5 --fudge --moar --keep-exit-code
Inline::Perl5 not installed: not running Perl 5 integration tests
Missing test file: t/spec/S02-magicals/GROUP.t
Missing test file: t/spec/S02-magicals/USER.t
Missing test file: t/spec/S02-one-pass-parsing/misc.t
Missing test file: t/spec/S02-types/baggy.t
Missing test file: t/spec/S02-types/mu.t
Missing test file: t/spec/S03-binding/nonsense.t
Missing test file: t/spec/S04-exceptions/exceptions-json.t
Missing test file: t/spec/S05-modifier/samemark.t
Missing test file: t/spec/S05-syntactic-categories/new-symbols.t
Missing test file: t/spec/S06-operator-overloading/circumfix.t
Missing test file: t/spec/S06-operator-overloading/infix.t
Missing test file: t/spec/S06-operator-overloading/prefix.t
Missing test file: t/spec/S07-iterators/range-iterator.t
Missing test file: t/spec/S09-typed-arrays/native-str.t
Missing test file: t/spec/S11-modules/module.t
Missing test file: t/spec/S11-modules/module-file.t
Missing test file: t/spec/S12-construction/destruction.t
Missing test file: t/spec/S12-construction/TWEAK.t
Missing test file: t/spec/S15-string-types/NF-types.t
Missing test file: t/spec/S15-string-types/NFK-types.t
Missing test file: t/spec/S16-filehandles/misc.t
Missing test file: t/spec/S16-filehandles/mode.t
Missing test file: t/spec/S16-io/eof.t
Missing test file: t/spec/S16-io/handles-between-threads.t
Missing test file: t/spec/S16-io/quoting-syntax.t
Missing test file: t/spec/S17-lowlevel/semaphore.t
Missing test file: t/spec/S17-procasync/encoding.t
Missing test file: t/spec/S17-supply/return-in-tap.t
Missing test file: t/spec/S19-command-line-options/04-negation.t
Missing test file: t/spec/S19-command-line-options/05-delimited-options.t
Missing test file: t/spec/S19-command-line-options/06-dash-rxtrace.t
Missing test file: t/spec/S24-testing/7-bail_out.t
Missing test file: t/spec/S24-testing/8-die_on_fail.t
Missing test file: t/spec/S24-testing/9-is_deeply.t
Missing test file: t/spec/S26-documentation/07a-tables-todo-skipped.t
Missing test file: t/spec/S29-any/deg-trans.t
Missing test file: t/spec/S32-basics/pairup.t
Missing test file: t/spec/S32-container/buf.t
Missing test file: t/spec/S32-hash/map.t
Missing test file: t/spec/S32-io/open.t
Missing test file: t/spec/S32-io/socket-accept-and-working-threads.t
Missing test file: t/spec/S32-list/categorize-list.t
Missing test file: t/spec/S32-list/classify-list.t
Missing test file: t/spec/S32-list/cross.t
Missing test file: t/spec/S32-list/deepmap.t
Missing test file: t/spec/S32-list/duckmap.t
Missing test file: t/spec/S32-list/first-end-kv.t
Missing test file: t/spec/S32-list/first-kv.t
Missing test file: t/spec/S32-str/parse-base.t

Test Summary Report
t/spec/S03-metaops/hyper.rakudo.moar                        (Wstat: 0
Tests: 402 Failed: 0)
  TODO passed:   115
t/spec/S05-modifier/counted-match.rakudo.moar               (Wstat: 0
Tests: 29 Failed: 0)
  TODO passed:   19-20, 25-27
t/spec/S05-substitution/subst.rakudo.moar                   (Wstat: 0
Tests: 179 Failed: 0)
  TODO passed:   63
t/spec/S15-nfg/regex.rakudo.moar                            (Wstat: 0
Tests: 12 Failed: 0)
  TODO passed:   10
t/spec/S26-documentation/09-configuration.rakudo.moar       (Wstat: 0
Tests: 17 Failed: 0)
  TODO passed:   8-10
t/spec/S32-io/IO-Socket-Async.t                             (Wstat: 65280
Tests: 2 Failed: 0)
  Non-zero exit status: 255
  Parse errors: Bad plan.  You planned 6 tests but ran 2.
t/spec/S32-io/pipe.t                                        (Wstat: 65280
Tests: 10 Failed: 0)
  Non-zero exit status: 255
  Parse errors: Bad plan.  You planned 14 tests but ran 10.
t/spec/S32-str/substr.rakudo.moar                           (Wstat: 0
Tests: 56 Failed: 0)
  TODO passed:   56
t/spec/integration/advent2012-day15.rakudo.moar             (Wstat: 0
Tests: 11 Failed: 0)
  TODO passed:   9
Files=1092, Tests=51347, 2226 wallclock secs (14.34 usr 33.79 sys + 1332.52
cusr 581.81 csys = 1962.46 CPU)
Result: FAIL
make[1]: *** [m-spectest5] Error 1

but install worked
andy@ANDY-HP:~/src/rakudo-star-2016.11$ perl6 -v
This is Rakudo version 2016.11 built on MoarVM version 2016.11
implementing Perl 6.c.



Andy Bach,
608 658-1890 cell
608 261-5738 wk

Reply via email to