See 
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/606/display/redirect?page=changes>

Changes:

[Dave Page] Fix tests for Python 3.x

------------------------------------------
Started by an SCM change
Started by an SCM change
Started by an SCM change
Started by an SCM change
[EnvInject] - Loading node environment variables.
Building in workspace 
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/>
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url git://git.postgresql.org/git/pgadmin4.git # 
 > timeout=10
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
Fetching upstream changes from git://git.postgresql.org/git/pgadmin4.git
 > git --version # timeout=10
 > git fetch --tags --progress git://git.postgresql.org/git/pgadmin4.git 
 > +refs/heads/*:refs/remotes/origin/*
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision 9c382e4d23aa66cf4ff18e25835c14a1c5fe3a9c (origin/master)
Commit message: "Fix tests for Python 3.x"
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 9c382e4d23aa66cf4ff18e25835c14a1c5fe3a9c
 > git rev-list 6f25f4d175482af42d64df524841728b493edf72 # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the 
SCM step.
[EnvInject] - Injecting as environment variables the properties content 
PYTHON_VERSION=2.6

[EnvInject] - Variables injected successfully.
[pgadmin4-master-python26] $ /bin/sh -xe /tmp/jenkins670880360516554552.sh
+ <https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/ci/ci_runner.sh>
EXECUTING: Create pgAdmin config

EXECUTING: Python tests

Creating Python 2.6 virtual environment...

New python executable in 
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/bin/python>
Installing setuptools, pip...done.
Running virtualenv with interpreter /usr/local/python-2.6/bin/python
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please 
upgrade your Python. A future version of pip will drop support for Python 2.6
Collecting wheel==0.29.0
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:318:
 SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name 
Indication) extension to TLS is not available on this platform. This may cause 
the server to present an incorrect TLS certificate, which can cause validation 
failures. You can upgrade to a newer version of Python to solve this. For more 
information, see 
https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:122:
 InsecurePlatformWarning: A true SSLContext object is not available. This 
prevents urllib3 from configuring SSL appropriately and may cause certain SSL 
connections to fail. You can upgrade to a newer version of Python to solve 
this. For more information, see 
https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
  Using cached wheel-0.29.0-py2.py3-none-any.whl
Collecting argparse; python_version == "2.6" (from wheel==0.29.0)
  Using cached argparse-1.4.0-py2.py3-none-any.whl
Installing collected packages: argparse, wheel
Successfully installed argparse-1.4.0 wheel-0.29.0
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please 
upgrade your Python. A future version of pip will drop support for Python 2.6
Ignoring Flask-HTMLmin: markers 'python_version >= "2.7"' don't match your 
environment
Collecting Babel==2.3.4 (from -r requirements.txt (line 4))
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:318:
 SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name 
Indication) extension to TLS is not available on this platform. This may cause 
the server to present an incorrect TLS certificate, which can cause validation 
failures. You can upgrade to a newer version of Python to solve this. For more 
information, see 
https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
<https://jenkins.pgadmin.org/job/pgadmin4-master-python26/ws/pgadmin-venv/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py>:122:
 InsecurePlatformWarning: A true SSLContext object is not available. This 
prevents urllib3 from configuring SSL appropriately and may cause certain SSL 
connections to fail. You can upgrade to a newer version of Python to solve 
this. For more information, see 
https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
  Using cached Babel-2.3.4-py2.py3-none-any.whl
Collecting beautifulsoup4==4.4.1 (from -r requirements.txt (line 5))
  Using cached beautifulsoup4-4.4.1-py2-none-any.whl
Collecting blinker==1.3 (from -r requirements.txt (line 6))
Collecting click==6.6 (from -r requirements.txt (line 7))
  Using cached click-6.6-py2.py3-none-any.whl
Collecting extras==0.0.3 (from -r requirements.txt (line 8))
Collecting fixtures==2.0.0 (from -r requirements.txt (line 9))
  Using cached fixtures-2.0.0-py2.py3-none-any.whl
Collecting Flask==0.11.1 (from -r requirements.txt (line 10))
  Using cached Flask-0.11.1-py2.py3-none-any.whl
Collecting Flask-Babel==0.11.1 (from -r requirements.txt (line 11))
Collecting Flask-Gravatar==0.4.2 (from -r requirements.txt (line 12))
  Using cached Flask_Gravatar-0.4.2-py2.py3-none-any.whl
Collecting Flask-Login==0.3.2 (from -r requirements.txt (line 14))
Collecting Flask-Mail==0.9.1 (from -r requirements.txt (line 15))
Collecting Flask-Migrate==2.0.3 (from -r requirements.txt (line 16))
Collecting Flask-Principal==0.4.0 (from -r requirements.txt (line 17))
Collecting Flask-Security==1.7.5 (from -r requirements.txt (line 18))
Collecting Flask-SQLAlchemy==2.1 (from -r requirements.txt (line 19))
Collecting Flask-WTF==0.12 (from -r requirements.txt (line 20))
  Using cached Flask_WTF-0.12-py2-none-any.whl
Collecting html5lib==1.0b3 (from -r requirements.txt (line 21))
Collecting importlib==1.0.3 (from -r requirements.txt (line 22))
Collecting itsdangerous==0.24 (from -r requirements.txt (line 23))
Collecting Jinja2==2.7.3 (from -r requirements.txt (line 24))
Collecting linecache2==1.0.0 (from -r requirements.txt (line 25))
  Using cached linecache2-1.0.0-py2.py3-none-any.whl
Collecting MarkupSafe==0.23 (from -r requirements.txt (line 26))
Collecting ordereddict (from -r requirements.txt (line 27))
Collecting passlib==1.6.2 (from -r requirements.txt (line 28))
Collecting pbr==1.9.1 (from -r requirements.txt (line 29))
  Using cached pbr-1.9.1-py2.py3-none-any.whl
Collecting psycopg2>=2.7.3.2 (from -r requirements.txt (line 30))
  Using cached psycopg2-2.7.4.tar.gz
    Complete output from command python setup.py egg_info:
    running egg_info
    creating pip-egg-info/psycopg2.egg-info
    writing pip-egg-info/psycopg2.egg-info/PKG-INFO
    writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt
    writing dependency_links to 
pip-egg-info/psycopg2.egg-info/dependency_links.txt
    writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'
    
    Error: pg_config executable not found.
    
    pg_config is required to build psycopg2 from source.  Please add the 
directory
    containing pg_config to the $PATH or specify the full executable path with 
the
    option:
    
        python setup.py build_ext --pg-config /path/to/pg_config build ...
    
    or with the pg_config option in 'setup.cfg'.
    
    If you prefer to avoid building psycopg2 from source, please install the 
PyPI
    'psycopg2-binary' package instead.
    
    For further information please check the 'doc/src/install.rst' file (also at
    <http://initd.org/psycopg/docs/install.html>).
    
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in 
/tmp/pip-build-azCP2w/psycopg2/
ERROR: Failed to install the application requirements.
ERROR: Error detected when running the Python tests.
Build step 'Execute shell' marked build as failure

Reply via email to