pg_class

Property | Value
Name | pg_class
OID | 1259
Owner | postgres
ACL | {=r}
Rows | 584
Inherited Tables Count | 0
Inherited Tables |
OIDs? | Yes
System Table? | Yes
Comment |
Sql | -- Table: pg_catalog.pg_class CREATE TABLE pg_catalog.pg_class ( relname name NOT NULL, relnamespace oid NOT NULL, reltype oid NOT NULL, relowner int4 NOT NULL, relam oid NOT NULL, relfilenode oid NOT NULL, relpages int4 NOT NULL, reltuples float4 NOT NULL, reltoastrelid oid NOT NULL, reltoastidxid oid NOT NULL, relhasindex bool NOT NULL, relisshared bool NOT NULL, relkind char(1) NOT NULL, relnatts int2 NOT NULL, relchecks int2 NOT NULL, reltriggers int2 NOT NULL, relukeys int2 NOT NULL, relfkeys int2 NOT NULL, relrefs int2 NOT NULL, relhasoids bool NOT NULL, relhaspkey bool NOT NULL, relhasrules bool NOT NULL, relhassubclass bool NOT NULL, relacl aclitem[], CONSTRAINT pg_class_oid_index UNIQUE (oid), CONSTRAINT pg_class_relname_nsp_index UNIQUE (relname, relnamespace) ) WITH OIDS; GRANT SELECT ON TABLE pg_catalog.pg_class TO PUBLIC;

pgAdmin II - PostgreSQL Tools

Copyright (C) 2001, 2003, The pgAdmin Development Team

This software is released under the pgAdmin Public Licence


Checks (0)

Check


Columns (31)

Column | Type | Comment
tableoid | oid |
cmax | cid |
xmax | xid |
cmin | cid |
xmin | xid |
oid | oid |
ctid | tid |
relname | name |
relnamespace | oid |
reltype | oid |
relowner | int4 |
relam | oid |
relfilenode | oid |
relpages | int4 |
reltuples | float4 |
reltoastrelid | oid |
reltoastidxid | oid |
relhasindex | bool |
relisshared | bool |
relkind | char |
relnatts | int2 |
relchecks | int2 |
reltriggers | int2 |
relukeys | int2 |
relfkeys | int2 |
relrefs | int2 |
relhasoids | bool |
relhaspkey | bool |
relhasrules | bool |
relhassubclass | bool |
relacl | aclitem[] |


tableoid

Property | Value
Name | tableoid
Position | -7
Data Type | oid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | Yes
Comment |


cmax

Property | Value
Name | cmax
Position | -6
Data Type | cid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | Yes
Comment |


xmax

Property | Value
Name | xmax
Position | -5
Data Type | xid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | Yes
Comment |


cmin

Property | Value
Name | cmin
Position | -4
Data Type | cid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | Yes
Comment |


xmin

Property | Value
Name | xmin
Position | -3
Data Type | xid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | Yes
Comment |


oid

Property | Value
Name | oid
Position | -2
Data Type | oid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | Yes
Comment |


ctid

Property | Value
Name | ctid
Position | -1
Data Type | tid
Length | 6
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | Yes
Comment |


relname

Property | Value
Name | relname
Position | 1
Data Type | name
Length | 64
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | -1
System Column? | No
Comment |


relnamespace

Property | Value
Name | relnamespace
Position | 2
Data Type | oid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | -1
System Column? | No
Comment |


reltype

Property | Value
Name | reltype
Position | 3
Data Type | oid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relowner

Property | Value
Name | relowner
Position | 4
Data Type | int4
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relam

Property | Value
Name | relam
Position | 5
Data Type | oid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relfilenode

Property | Value
Name | relfilenode
Position | 6
Data Type | oid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relpages

Property | Value
Name | relpages
Position | 7
Data Type | int4
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


reltuples

Property | Value
Name | reltuples
Position | 8
Data Type | float4
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


reltoastrelid

Property | Value
Name | reltoastrelid
Position | 9
Data Type | oid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


reltoastidxid

Property | Value
Name | reltoastidxid
Position | 10
Data Type | oid
Length | 4
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relhasindex

Property | Value
Name | relhasindex
Position | 11
Data Type | bool
Length | 1
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relisshared

Property | Value
Name | relisshared
Position | 12
Data Type | bool
Length | 1
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relkind

Property | Value
Name | relkind
Position | 13
Data Type | char
Length | 1
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | -1
System Column? | No
Comment |


relnatts

Property | Value
Name | relnatts
Position | 14
Data Type | int2
Length | 2
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relchecks

Property | Value
Name | relchecks
Position | 15
Data Type | int2
Length | 2
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


reltriggers

Property | Value
Name | reltriggers
Position | 16
Data Type | int2
Length | 2
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relukeys

Property | Value
Name | relukeys
Position | 17
Data Type | int2
Length | 2
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relfkeys

Property | Value
Name | relfkeys
Position | 18
Data Type | int2
Length | 2
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relrefs

Property | Value
Name | relrefs
Position | 19
Data Type | int2
Length | 2
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relhasoids

Property | Value
Name | relhasoids
Position | 20
Data Type | bool
Length | 1
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relhaspkey

Property | Value
Name | relhaspkey
Position | 21
Data Type | bool
Length | 1
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relhasrules

Property | Value
Name | relhasrules
Position | 22
Data Type | bool
Length | 1
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relhassubclass

Property | Value
Name | relhassubclass
Position | 23
Data Type | bool
Length | 1
Numeric Precision |
Default |
Restrict Nulls? | Yes
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


relacl

Property | Value
Name | relacl
Position | 24
Data Type | aclitem[]
Length | Variable
Numeric Precision |
Default |
Restrict Nulls? | No
Primary Key? | No
Statistics | 0
System Column? | No
Comment |


Foreign Keys (0)

Foreign Key References


Indexes (2)

Index | Comment
pg_class_oid_index |
pg_class_relname_nsp_index |


pg_class_oid_index

Property | Value
Name | pg_class_oid_index
OID | 16612
Index Type | btree
Unique? | Yes
Primary? | No
Column Count | 1
Columns | oid
Constraint |
System Index? | No
Comment |
Sql | -- Index: pg_catalog.pg_class_oid_index CREATE UNIQUE INDEX pg_class_oid_index ON pg_class USING btree (oid);


pg_class_relname_nsp_index

Property | Value
Name | pg_class_relname_nsp_index
OID | 16613
Index Type | btree
Unique? | Yes
Primary? | No
Column Count | 2
Columns | relname, relnamespace
Constraint |
System Index? | No
Comment |
Sql | -- Index: pg_catalog.pg_class_relname_nsp_index CREATE UNIQUE INDEX pg_class_relname_nsp_index ON pg_class USING btree (relname, relnamespace);


Rules (0)

Rule Comment


Triggers (0)

Trigger Comment