On 18-10-2016 01:49, Amir wrote:
> Olá... Após atualizar o Postgresql da versão 9.3 para a 9.6.0, importei
> através de roteiro de carga SQL a minha base que passou a funcionar
> normalmente no sistema para testes desta versão... mas deste então ao
> disparar o comando de cópia automática F:\so_copias\pg_dump.exe --file
> "g:\\hrb0023" --host "localhost" --port "3815" --username "postgres"
> --no-password --verbose --role "sistema" --format=c --blobs "hrb_0023"
>  o banco devolve o seguinte erro 'utf8' codec can't decode byte 0xa0 in
> position 49: invalid start byte...
> 
Esse é um erro do Python. Ese comando está sendo disparado pelo pgAdmin 4?

Suas informações ficaram confusas/incompletas. O erro ocorre ao tentar
fazer o backup da versão 9.3 ou da 9.6? Qual é a codificação do banco
"hrb_0023" de ambas as versões (vide comando abaixo)?

SELECT datname,pg_encoding_to_char(encoding) FROM pg_database WHERE
datistemplate IS FALSE

> Então instalei o pgAdmin 4, o qual funciona normalmente, mas não retorna
> os ‘backup’ da versão 9.3 e apresenta o mesmo erro quando vou executar
> um cópia geral da base (backup). 
> 
Como foi feito esse backup na versão 9.3 (digo, qual o comando completo)?


-- 
   Euler Taveira                   Timbira - http://www.timbira.com.br/
   PostgreSQL: Consultoria, Desenvolvimento, Suporte 24x7 e Treinamento
_______________________________________________
pgbr-geral mailing list
pgbr-geral@listas.postgresql.org.br
https://listas.postgresql.org.br/cgi-bin/mailman/listinfo/pgbr-geral

Responder a