Remove overzeleous assertions in pg_atomic_flag code.

The atomics code asserts proper alignment in various places. That's
mainly because the alignment of 64bit integers is not sufficient for
atomic operations on all platforms. Some ABIs only have four byte
alignment, but don't have atomic behavior when crossing page
boundaries.

The flags code isn't affected by that however, as the type alignment
always is sufficient for atomic operations. Nevertheless the code
asserted alignment requirements. Before 8c3debbb it was only broken on
hppa, after it probably affect further platforms.

Thus remove the assertions for pg_atomic_flag operators.

Per buildfarm animal pademelon.

Discussion: https://postgr.es/m/7223.1523124...@sss.pgh.pa.us
Backpatch: 9.5-

Branch
------
REL9_5_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/e68d64c52831eb2be013da4eb0e0bf9255c8bd7a

Modified Files
--------------
src/include/port/atomics.h | 8 --------
1 file changed, 8 deletions(-)

Reply via email to