Provide a better error message for misplaced dispatch options. Before this patch, misplacing a special must-be-first option for dispatching to a subprogram (e.g., postgres -D . --single) would fail with an error like
FATAL: --single requires a value This patch adjusts this error to more accurately complain that the special option wasn't listed first. The aforementioned error message now looks like FATAL: --single must be first argument The dispatch option parsing code has been refactored for use wherever ParseLongOption() is called. Beyond the obvious advantage of avoiding code duplication, this should prevent similar problems when new dispatch options are added. Note that we assume that none of the dispatch option names match another valid command-line argument, such as the name of a configuration parameter. Ideally, we'd remove this must-be-first requirement for these options, but after some investigation, we decided that wasn't worth the added complexity and behavior changes. Author: Nathan Bossart, Greg Sabino Mullane Reviewed-by: Greg Sabino Mullane, Peter Eisentraut, Álvaro Herrera, Tom Lane Discussion: https://postgr.es/m/CAKAnmmJkZtZAiSryho%3DgYpbvC7H-HNjEDAh16F3SoC9LPu8rqQ%40mail.gmail.com Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/76fd342496612c8432ef8f6c71794c935497d3c9 Modified Files -------------- src/backend/bootstrap/bootstrap.c | 15 ++++++- src/backend/main/main.c | 86 +++++++++++++++++++++++++++++++------ src/backend/postmaster/postmaster.c | 15 ++++++- src/backend/tcop/postgres.c | 15 ++++++- src/include/postmaster/postmaster.h | 17 ++++++++ src/tools/pgindent/typedefs.list | 1 + 6 files changed, 133 insertions(+), 16 deletions(-)