Rename sort support integer comparators for clarity The previous names used "unsigned" for Datum-width abbreviated keys and "signed" for 64-bit signed integers. This may have made more sense when Datum width was platform-dependent, but commit 805c64f84 added a 32-bit unsigned variant for OIDs, so it makes even less sense now. Rename all to be explicit about signedness and width.
Suggested-by: David Rowley <[email protected]> Discussion: https://postgr.es/m/CAApHDvrNMz5ahN1x=uK9yscTogmLupfLBy-_qMW9Z+k=he5...@mail.gmail.com Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/19733fa0b42caffa92463bb8a8098a40d8963d76 Modified Files -------------- src/backend/access/gist/gistproc.c | 2 +- src/backend/access/nbtree/nbtcompare.c | 4 ++-- src/backend/utils/adt/bytea.c | 4 ++-- src/backend/utils/adt/mac.c | 4 ++-- src/backend/utils/adt/network.c | 2 +- src/backend/utils/adt/timestamp.c | 2 +- src/backend/utils/adt/uuid.c | 4 ++-- src/backend/utils/adt/varlena.c | 4 ++-- src/backend/utils/sort/tuplesort.c | 12 ++++++------ src/include/utils/sortsupport.h | 4 ++-- 10 files changed, 21 insertions(+), 21 deletions(-)
