Rename EXISTS-to-ANY converted subplan to exists_to_any Simple EXISTS subplans can be converted to hashed ANY subplans as an alternative implementation. Previously, both the original EXISTS subplan and the converted ANY subplan used names with the exists_ prefix, making EXPLAIN output harder to read and pg_plan_advice targets less clear.
Use the exists_to_any_ prefix for converted ANY subplans so that their names distinguish them from the original EXISTS alternative. This only changes the names shown by EXPLAIN and used by plan advice; it does not affect planner behavior. Author: Yugo Nagata <[email protected]> Reviewed-by: Tom Lane <[email protected]> Reviewed-by: solai v <[email protected]> Reviewed-by: Fujii Masao <[email protected]> Discussion: https://postgr.es/m/[email protected] Backpatch-through: 19 Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/7b7c4a8dcc933f61493356a45256b47783ce404f Modified Files -------------- contrib/pg_plan_advice/expected/alternatives.out | 30 ++++++++++++------------ contrib/pg_plan_advice/sql/alternatives.sql | 2 +- src/backend/optimizer/plan/subselect.c | 8 +++++-- src/test/regress/expected/partition_prune.out | 10 ++++---- src/test/regress/expected/subselect.out | 16 ++++++------- 5 files changed, 35 insertions(+), 31 deletions(-)
