Fix slot names in the standby slot removal check The DROP DATABASE test in 035_standby_logical_decoding.pl created slots with the prefix "drop_db_" but checked for their removal using "drop_db". Sined names never existed, the checks passed even if the actual slots remained.
Fix this by using the correct prefix when checking for slot removal. Backpatch to v16, where this testce the check was introduced. Author: Fujii Masao <[email protected]> Reviewed-by: Hayato Kuroda <[email protected]> Discussion: https://postgr.es/m/CAHGQGwEnuLZnFRF5CzK47n_hXT-iCXnzirxG2v_V-=qnmlk...@mail.gmail.com Backpatch-through: 16 Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/d6cf162f74a89bd717ed4439e946aabf4317bc46 Modified Files -------------- src/test/recovery/t/035_standby_logical_decoding.pl | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
