ci: Move to per-job naming for containers Previously we only had two types of containers, "ci" for everything but the CompilerWarnings job and ci_docs that had the tools necessary to build the docs as part of CompilerWarnings. But that was unnecessarily heavy for several of the jobs. As the pull time is a noticeable performance factor, that's not great.
Instead use containers that are named by their job. Today some of those are the same, but after this change we can optimize the containers for their jobs without a problem. It probably would make sense to allow over-riding CONTAINER_REPO on a per-repo/org basis, but that seems better done as a separate change. This commit is backpatched to 19 to keep CI between master and 19 the same. Soon we'll backpatch CI support to regain coverage with lost with cirrus-ci's shutdown. Author: Andres Freund <[email protected]> Co-authored-by: Nazir Bilal Yavuz <[email protected]> Discussion: https://postgr.es/m/a2ejn7lfqolutzz7kozalbhy3bixdrujb4buc3pgbtlk4am2ba@wbv6v7riia33 Discussion: https://postgr.es/m/can55fz1bcwbswgcck2gqkyn6tzdxcw2hvk2m3qeiwanxunj...@mail.gmail.com Backpatch-through: 19 Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/29fffc1a66456babfba35771b9ec644e3137164a Modified Files -------------- .github/workflows/pg-ci.yml | 33 ++++++++++++++++++++++----------- 1 file changed, 22 insertions(+), 11 deletions(-)
