On Wed, Jul 22, 2026 at 1:35 PM Peter Smith <[email protected]> wrote:
> So, the suggested synopsis change might seem good today, but in a
> couple of years IMO we'd probably want to change it back again.

Your point seems reasonable to me. So, how about keeping a reusable
production, but making it represent the entire EXCEPT table list
instead of a single list element?

    ALL TABLES [ EXCEPT ( except_table_list ) ]
    where except_table_list is:
        TABLE table_object [, [ TABLE ] table_object ] ...

This avoids having list notation in both the EXCEPT clause and the definition
of except_table_object, which makes the current synopsis a bit hard to read.
It also keeps the EXCEPT syntax probably reusable for future command support.

Regards,

-- 
Fujii Masao


Reply via email to