Awhile back I wrote:
> Peter Eisentraut <> writes:
>> The questions for those who are building PDFs are
>> - Can you make the build work?

> * On RHEL 6: the available version of fop is 0.95, and it just fails
> completely.  It looks like <title id="..."> constructs cause a
> NullPointerException in some cases.  I tried installing fop 1.0
> from back-rev Fedora SRPMs, but ran into dependency hell and gave
> up for the time being.  I didn't look into whether the binary
> downloads available from would work.

I got around to trying the binary-download solution today.
The binary tarballs available from
are definitely recommendable: they contain essentially a bunch
of jars and an invocation shell script, and they work great even
with RHEL6's none-too-shiny-new JRE.  You just need to unpack the
tarball someplace and put a symlink to its included "fop" script
into your PATH.

I initially tried the fop-2.0 tarball, and got a NullPointerException
on today's HEAD docs, which seems odd because the version of fop 2.0
included in Fedora 25 works.  I suppose Red Hat is carrying some
patches in their distribution, but I didn't look more closely.

However, the fop-2.2 tarball works just fine.  (No need for tweaking
memory settings either, although it does bloat to multiple GB while
running.)  So we could recommend 2.2 or later for people going this

                        regards, tom lane

Sent via pgsql-docs mailing list (
To make changes to your subscription:

Reply via email to