On 02/13/2018 03:08 PM, Sherman Willden wrote:
Yes the double quotes worked. I tried single quotes but since that didn't work I just assumed that double quotes would not work either.

The below explains why:


Thanks all;


On Tue, Feb 13, 2018 at 1:41 PM, Adrian Klaver <adrian.kla...@aklaver.com <mailto:adrian.kla...@aklaver.com>> wrote:

    On 02/13/2018 12:38 PM, Sherman Willden wrote:

        development platform: HP Compaq 6710b
        postgresql 9.6
        Operating System: Ubuntu 17.10

        It probably doesn't matter since there is nothing in the
        database. I don't remember  how I created the database. It
        appears that postgresql does not like a dash in the database
        name. I have not tried to create a table under the database.
        When I try to drop the database I get the following..

        date_time=# DROP DATABASE test-aria;
        ERROR:  syntax error at or near "-"
        LINE 1: DROP DATABASE test-aria;

    DROP DATABASE "test-aria";

    See below for more info:




-- Adrian Klaver
    adrian.kla...@aklaver.com <mailto:adrian.kla...@aklaver.com>

Adrian Klaver

Reply via email to