Em 18-10-2016 11:33, Melvin Davidson escreveu:



On Tue, Oct 18, 2016 at 10:20 AM, Edilmar LISTAS
<edili...@intersite.com.br <mailto:edili...@intersite.com.br>> wrote:

    1) I changed /etc/rc.d/init.d/postgresql-9.6 like this:
    PGDATA=/sistemas/sat4/bdpg
    #PGDATA=/var/lib/pgsql/9.6/data

    2) I copied postgresql.conf and pg_hba.conf from
    /var/lib/pgsql/9.6/data to /sistemas/sat4/bdpg

    3) I changed postgresql.conf like this:
    data_directory = '/sistemas/sat4/bdpg'

    4) service postgresql-9.6 start
    Iniciando o serviço postgresql-9.6: [FAILED]

    In my devel machine, I only did step 3), PG starts lookup for
    default configs in /var/lib/pgsql/data and uses my databases in the
    alternative path /sistemas/sat4/bdpg.


    Em 17-10-2016 21:22, Adrian Klaver escreveu:

        On 10/17/2016 01:38 PM, Edilmar LISTAS wrote:

            I have an env running a changed data_directory fine in a
            devel machine
            PG 9.4 using Fedora23.
            Now, I have a server machine with CentOS where I downloaded
            the RPMs
            from repo
            
https://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-6-x86_64/pgdg-centos96-9.6-3.noarch.rpm
            
<https://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-6-x86_64/pgdg-centos96-9.6-3.noarch.rpm>.

            All the configs run fine if I doesn't change the default
            data_directory.
            But I need to use the path /sistemas/sat4/bdpg.

            I did these commands:

            mkdir /sistemas/sat4/bdpg
            chown postgres /sistemas/sat4/bdpg
            chmod 700 /sistemas/sat4/bdpg
            su - postgres
            /usr/pgsql-9.6/bin/initdb -D /sistemas/sat4/bdpg
            exit

            Then, I changed data_directory to /sistemas/sat4/bdpg and
            tried to


        Changed data_directory where?

            restart PG:
            service postgresql-9.6 restart
            STOP => OK
            START => FAILED

            I disabled se_linux.
            The file /var/lib/pgsql/9.6/pgstartup.log just said to see
            future output
            in pg_log.
            The file data/pg_log/postgresql-Mon.log doesn't say anything
            about
            errors.

            The strange is that startup arises a FAILED message, but the
            process
            "/usr/pgsql-9.6/bin/postmaster -D /var/lib/pgsql/9.6/data"
            is running


        So /var/lib/pgsql/9.6/data is where the original install is?

        Best guess is that some script is starting the original install
        and when
        you go to start your custom location it fails because the new
        cluster is
        trying to use the port(5432 I am assuming) as the original cluster.

        Have you tried giving the new cluster a different port number,
        say 5442,
        and the starting it?


            (and the children logger/checkpointer/etc). But I don't get
            to connect
            using pgAdmin3. Then, I have to kill manually postmaster
            (because
            service script doesn't understand postmaster.pid in the new
            data dir),
            comment data_directory to use default place, start and
            connect to
            pgAdmin3. Then, start/stop/start/etc run fine lookup for
            postmaster.pid
            in /var/lib/pgsql/9.6/data.


        So you either need to change the start script to point to the new
        cluster or create a new one for it.






    --
    Sent via pgsql-general mailing list (pgsql-general@postgresql.org
    <mailto:pgsql-general@postgresql.org>)
    To make changes to your subscription:
    http://www.postgresql.org/mailpref/pgsql-general
    <http://www.postgresql.org/mailpref/pgsql-general>



I*nstead of
4) service postgresql-9.6 start
*
*
Try:
*
*sudo su postgres
*
*pg_ctl start -D /sistemas/sat4/bdpg*
*
*
*If that works, then your problem is in the postgresql service file
*
*-- *
*Melvin Davidson*
I reserve the right to fantasize.  Whether or not you
wish to share my fantasy is entirely up to you.

This works...
/usr/pgsql-9.6/bin/pg_ctl -D /sistemas/sat4/bdpg -l logfile start
but psql doesn't log:
-bash-4.1$ psql
Senha:
psql: fe_sendauth: no password supplied

If I use the default data_directory = /var/lib/pgsql/9.6/data, psql runs fine without password.


--
Sent via pgsql-general mailing list (pgsql-general@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-general

Reply via email to