> 7 марта 2018 г., в 3:25, Tels <nospam-pg-ab...@bloodgate.com> написал(а):
> It could be named "SkipTuples" (e.g. this is the number of tuples we need
> to skip, not the number we have skipped), and the other one then
> "iss_SkipTuplesRemaining" so they are consistent with each other.
I agree that name sounds strange (even for my globish ear).
I'm not sure, but may be this
! Assert(!(scandesc->numberOfOrderBys > 0 &&
should be if() elog(ERROR,...); ?
Also, I think that this check could be removed from loop. We do not expect that
it's state will change during execution, do we?
Besides this, I think the patch is ready for committer.
Best regards, Andrey Borodin.