On Wed, 9 Aug 2023 at 09:19, Peter Eisentraut <[email protected]> wrote:
> 1. As was discussed, these definitions should go into > src/include/libpq/pqcomm.h, not a new file. > I'm ambivalent, this is very easy to do. > > 2. I would prefer an underscore after PgMsg, like PqMsg_DescribeRequest, > so it's easier to visually locate the start of the actual message name. > > 3. IMO, the names of the protocol messages in protocol.sgml are > canonical. Your patch appends "Request" and "Response" in cases where > that is not part of the actual name. Also, some messages are documented > to go both ways, so this separation doesn't make sense strictly > speaking. Please use the names as in protocol.sgml without augmenting > them. > > I've changed this a number of times. I do not mind changing it again, but can we reach a consensus ? Dave
