Bruce Momjian <[email protected]> writes:
> I am thinking "enable_alter_system_command" is probably good because we
> already use "enable" so why not reuse that idea, and I think "command"
> is needed because we need to clarify we are talking about the command,
> and not generic altering of the system. We could use
> "enable_sql_alter_system" if people want something shorter.
Robert already mentioned why not use "enable_": up to now that prefix
has only been applied to planner plan-type-enabling GUCs. I'd be okay
with "allow_alter_system_command", although I find it unnecessarily
verbose.
> Will people think this allows non-root users to use ALTER SYSTEM if
> enabled?
They'll soon find out differently, so I'm not concerned about that.
regards, tom lane