Hi Kyotaro, Thank you for the review and the helpful feedback.
You are absolutely right that I should have included the motivation. The original intent was to reduce code duplication and use the existing `wait_for_log()` helper for better consistency in the test suite. I understand your concern about not touching functioning test code without a strong functional reason. Also, I agree with your point about inconsistency, leaving some tests using `wait_for_log()` while others (like `033_replay_tsp_drops.pl`) use open-coded log searches makes the codebase less uniform. To address this, I've decided to take the broader approach. I am currently reviewing the rest of the test suite to find similar open-coded usages. I will prepare and submit a v2 patch that standardizes all these instances to use `wait_for_log()` together. Thanks again for pointing me in the right direction. I'll follow up with the updated patch shortly. Best Regards, Zakariyah Ali.
