On Fri, 17 Jul 2026, 08:24 Daniel Gustafsson, <[email protected]> wrote:
> > On 17 Jul 2026, at 08:44, Ian Lawrence Barwick <[email protected]> > wrote: > > > It was noted here [1] that we have the undocumented SQL function > > "getdatabaseencoding()", used mainly in regression tests and a couple > > of psql queries. While considering a documentation patch, it occurred > > to me that it's a horrible function name which doesn't look like other > > public functions, and we already have "pg_client_encoding()", so why not > > rename it to match that while we're at it? > > This function seems to be referred to in extensions, how about adding > keeping > the existin name and adding the new name as an alias? It would keep > existing > code from breaking and cause less churn in the code. > Why don't extensions use current_setting('server_encoding')? Thom >
