> Patch attached. I've renamed the patch file to > v5-0001-pg_upgrade-initdb.patch to match our naming convention. No > content change, just the filename. Happy to walk through any of this > in more detail. >
One more thing. While checking this against the CI build I found one more small bug: a log message in the new --check --initdb dry-run path had a trailing newline character it shouldn't have had, which tripped an internal safety check and caused a crash — but only on that stricter CI build, not on a normal build. Fixed by removing the extra newline. v5 is now confirmed working on both build types.
v5-0001-pg_upgrade-initdb.patch
Description: Binary data
