Richard Guo <[email protected]> writes:
> On Tue, Sep 1, 2026 at 12:56 AM Tom Lane <[email protected]> wrote:
>> * I feel like the naming of remove_redundant_nullability_quals
>> and remove_redundant_nullability_quals_recurse is a bit weird.
>> Usually our pattern is that a function named like foo_recurse
>> is an inner workhorse for a function named foo.  This is the
>> other way around, which seems like it'd confuse readers.

> I've renamed the jointree walker to remove_redundant_nullability_quals
> (it recurses into itself, so there is no wrapper to pair a "_recurse"
> with), and the helper that processes one qual list to
> strip_redundant_nullability_quals.  Not sure if this is the best
> naming though.

Yeah, naming is always hard.  I don't have a better suggestion than
this.

v2 patch LGTM.  I might say "incomplete" rather than "one-sided"
in the commit message, but that's getting *really* nit-picky.

                        regards, tom lane


Reply via email to