The patch 001 looks good to me. I had just one comment which I noticed
Kuroda-San has already covered.

ReplicationSlotMarkDirty();
ReplicationSlotSave();
These calls are only needed if xmin is adjusted.
--

Now, the better names for 'init_conflict_slot_xmin' could be:
adjust_conflict_slot_xmin, refresh_conflict_slot_xmin.

--

Also would it be better if we change elog to:

if (!TransactionIdIsValid(old_xmin))
elog(DEBUG1, "initialized conflict detection slot's xmin to %u", xmin_horizon);
else
elog(DEBUG1, "adjusted conflict detection slot's xmin from %u to %u",
old_xmin, xmin_horizon);

<Do it only if you find it better>

thanks
Shveta


Reply via email to