On 23/06/2026 09:48, Jeevan Chalke wrote:
* Naming. I went with PRODUCT(); other systems and discussions have used names like PROD or MUL. Happy to change it if there is a consensus.
Hi! It should be called PRODUCT and it should accept the syntax PRODUCT(col, 1 ON EMPTY) for when there are no non-nulls in the input.This will be required by the next edition of the SQL standard. The exact value "1" is required by the standard, but I think we should allow any a_expr there.
-- Vik Fearing
