I think making ERROR a reserved word is a terrible idea, and we don't need it for this feature anyway. Use a new option in the parenthesized options list instead.
error_limit being an integer, please don't use it as a boolean: if (cstate->error_limit) ... Add an explicit comparison to zero instead, for code readability. Also, since each error decrements the same variable, it becomes hard to reason about the state: at the end, are we ending with the exact number of errors, or did we start with the feature disabled? I suggest that it'd make sense to have a boolean indicating whether this feature has been requested, and the integer is just the remaining allowed problems. Line 3255 or thereabouts contains an excess " char The "warn about it" comment is obsolete, isn't it? There's no warning there. -- Álvaro Herrera https://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services