On 2020-03-20 17:36, Tom Lane wrote:
One small point is that I believe the existing code has the effect of "#define EXEC_BACKEND 1" not just "#define EXEC_BACKEND". I don't think this matters to anyplace in the core code, but it's conceivable that somebody has extension code written to assume the former. Nonetheless, I'm +1 for re-standardizing on the latter, because it's a couple less keystrokes when inserting a manual definition ;-). Might be worth mentioning in the commit log entry though.
Ok, done that way. -- Peter Eisentraut http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services