> On 19 Aug 2021, at 05:08, Tom Lane <[email protected]> wrote: > > Peter Smith <[email protected]> writes: >> On Thu, Aug 19, 2021 at 4:29 AM Justin Pryzby <[email protected]> wrote: >>> - state->oneCol = (origTupdesc->natts == 1) ? true : false; >>> + state->oneCol = origTupdesc->natts == 1; > > FWIW, I am definitely not a fan of removing the parentheses in this > context, because readers might wonder if you meant an "a = b = 1" > multiple-assignment, or even misread it as that and be confused. > So I'd prefer > > state->oneCol = (origTupdesc->natts == 1);
+1, the parenthesis makes it a lot more readable IMO. -- Daniel Gustafsson https://vmware.com/
