* Ali Dar (ali.munir....@gmail.com) wrote: > Find attached an initial patch for ALTER RENAME RULE feature. Please > note that it does not have any documentation yet.
Just took a quick look through this. Seems to be alright, but why do we allow renaming ON SELECT rules at all, given that they must be named _RETURN? My thinking would be to check for that case and error out if someone tries it. You should try to keep variables lined up: Relation pg_rewrite_desc; HeapTuple ruletup; + Oid owningRel; should be: Relation pg_rewrite_desc; HeapTuple ruletup; + Oid owningRel; I'd also strongly recommend looking through that entire function very carefully. Code that's been #ifdef'd out tends to rot. Thanks, Stephen
signature.asc
Description: Digital signature