Noah Misch <> writes:
> That's how I read it, too.  My hypothesis is that the standard adopted TABLE()
> to rubber-stamp Oracle's traditional name for UNNEST().

Hmm ... plausible.

> ... I propose merely changing the syntax to "TABLE FOR ROWS (...)".

Ugh :-(.  Verbose and not exactly intuitive, I think.  I don't like
any of the other options you listed much better.  Still, the idea of
using more than one word might get us out of the bind that a single
word would have to be a fully reserved one.


This one's a little less awful than the rest.  What about "ROWS OF"?

                        regards, tom lane

Sent via pgsql-hackers mailing list (
To make changes to your subscription:

Reply via email to