On Mon, Dec 16, 2013 at 6:00 AM, Ants Aasma <ants.aa...@eesti.ee> wrote:

> On Dec 15, 2013 6:44 PM, "Tom Lane" <t...@sss.pgh.pa.us> wrote:
> > David Rowley <dgrowle...@gmail.com> writes:
> > > I've attached an updated patch which includes some documentation.
> > > I've also added support for negfunc in CREATE AGGREGATE. Hopefully
> that's
> > > an ok name for the option, but if anyone has any better ideas please
> let
> > > them be known.
> >
> > I'd be a bit inclined to build the terminology around "reverse" instead
> of
> > "negative" --- the latter seems a bit too arithmetic-centric.  But that's
> > just MHO.
> To contribute to the bike shedding, inverse is often used in similar
> contexts.
I guess it's not really bike shedding, most of the work I hope is done, so
I might as well try to get the docs polished up and we'd need a consensus
on what we're going to call them before I can get that done.

I like both of these better than negative transition function and I agree
negative implies arithmetic rather than opposite.
Out of these 2 I do think inverse fits better than reverse, so I guess that
would make it "inverse aggregate transition function".
Would that make the CREATE AGGREGATE option be INVFUNC ?

Any other ideas or +1's for any of the existing ones?


David Rowley

> --
> Ants Aasma

Reply via email to