On 14/01/14 14:29, Tom Lane wrote:
(2) the float and numeric variants should be implemented under
nondefault names (I'm thinking FAST_SUM(), but bikeshed away). People
who need extra speed and don't mind the slightly different results can
alter their queries to use these variants. One reason I'm thinking
this is that whatever we do to ameliorate the semantic issues is going
to slow down the forward transition function --- to no benefit unless
the aggregate is being used as a window function in a moving window.
So I'm less than convinced that we *should* implement any of these
designs in the default aggregates, even if we get to the point where
we arguably *could* do it with little risk of functional differences.
regards, tom lane
How SUM_FAST() instead, then it will more likely to be close to SUM() in
Sent via pgsql-hackers mailing list (firstname.lastname@example.org)
To make changes to your subscription: