Hi Pavel,

First of all, thanks for working on this!

On 1/12/14, 8:58 PM, Pavel Stehule wrote:
I still not happy with plugin_info - it is only per plugin now and should
be per plugin and per function.

I'm not sure I understand the point of plugin_info in the first place, but what would having a separate info per (plugin, function) achieve that can't be done otherwise?

As for the current patch, I'd like to see improvements on a few things:

  1) It doesn't currently compile because of extra semicolons in the
     PLpgSQL_plugin struct.

  2) The previous comment above the same struct still talk about the
     rendezvous variable which is now gone.  The comment should be
     updated to reflect the new API.

  3) The same comment talks about how important it is to unregister a
     plugin if its _PG_fini() is ever called, but the current API does
     not support unregistering.  That should probably be added?  I'm not
     sure when _PG_fini() would be called.

  4) The comment  /* reserved for use by optional plugin */  seems a bit
     weird in its new context.

Marko Tiikkaja

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to