* Dimitri Fontaine (dimi...@2ndquadrant.fr) wrote:
> Stephen Frost <sfr...@snowman.net> writes:
> >>    # hstore extension
> >>    comment = 'data type for storing sets of (key, value) pairs'
> >>    default_version = '1.3'
> >>    directory = 'local/hstore-new'
> >>    module_pathname = '$directory/hstore'
> >>    relocatable = true
> >
> > Interesting idea.  I'm a *little* concerned that re-useing '$directory'
> > there might confuse people into thking that any values in the control
> > file could be substituted in a similar way though.  Would there really
> > be much difference between that and '$ctldir' or something?
> Well, using $directory makes the feature auto-documented and very easy
> to read even without the reference documentation handy. It's also a very
> known way to setup things in .ini files.
> Now, what other parameters would you possibly use that way, other than
> $directory? I can see a use for $default_version, but that's about it.

Yeah, default_version was the other one that looked like it might be
possible to include, but folks might decide to try and use 'comment' in
that way too.  Basically, there's a chance that they'd want to use any
string in there.

> Would you rather add support for $default_version in the patch, for all
> of the parameters just in case, for a different set of control
> parameters, or rename the $directory macro?
> My vote goes for adding $default_version only.

It certainly seems to me that people will natuarlly want to use
$default_version.  I'm trying to figure out if that's actually something
we should encourage or what.  Of course, including it and/or the
PG_MODULE_MAGIC that I mentioned in my previous email run afoul of our
current 'upgrade-all-the-things' strategy when changing major versions.
I continue to wonder if that was really the best idea.



Attachment: signature.asc
Description: Digital signature

Reply via email to