Gavin Flower <> writes:
> On 09/05/14 15:34, Bruce Momjian wrote:
>> Looks good.  I was thinking the jsonb_ops name could remain unchanged
>> and the jsonb_hash_ops could be called jsonb_combo_ops as it combines
>> the key and value into a single index entry.

> If you have 'jsonb_combo_ops' - then surely 'jsonb_op' should be called 
> 'jsonb_xxx_ops', where the 'xxx' distinguishes that from 
> 'jsonb_combo_ops'?  I guess, if any appropriate wording of 'xxx' was too 
> cumbersome, then it would be worse.

Yeah, I'm disinclined to change the opclass names now.  It's not apparent
to me that "combo" is a better choice than "hash" for the second opclass.

                        regards, tom lane

Sent via pgsql-hackers mailing list (
To make changes to your subscription:

Reply via email to