On Thu, Aug 7, 2014 at 11:16 AM, Simon Riggs <si...@2ndquadrant.com> wrote:
> On 7 August 2014 14:53, Robert Haas <robertmh...@gmail.com> wrote:
>> On Wed, Aug 6, 2014 at 4:06 PM, Nicolas Barbier
>> <nicolas.barb...@gmail.com> wrote:
>>> 2014-08-06 Claudio Freire <klaussfre...@gmail.com>:
>>>> So, I like blockfilter a lot. I change my vote to blockfilter ;)
>>> +1 for blockfilter, because it stresses the fact that the "physical"
>>> arrangement of rows in blocks matters for this index.
>> I don't like that quite as well as summary, but I'd prefer either to
>> the current naming.
> Yes, "summary index" isn't good. I'm not sure where the block or the
> filter part comes in though, so -1 to "block filter", not least
> because it doesn't have a good abbreviation (bfin??).

Block filter would refer to the index property that selects blocks,
not tuples, and it does so through a "filter function" (for min-max,
it's a range check, but for other opclasses it could be anything).

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to