On 13 November 2014 15:35 Amit Kapila Wrote,

>As mentioned by you offlist that you are not able reproduce this
>issue, I have tried again and what I observe is that I am able to
>reproduce it only on *release* build and some cases work without
>this issue as well,
>./vacuumdb --analyze-in-stages -t t1 -t t2 -t t3 -t t4 -t t5 -t t6 -t t7 -t t8 
>-j 8 -d postgres
>Generating minimal optimizer statistics (1 target)
>Generating medium optimizer statistics (10 targets)
>Generating default (full) optimizer statistics

>So to me, it looks like this is a timing issue and please notice
>why in error the statement looks like
>"ANALYZE ng minimal optimizer statistics (1 target)".  I think this
>is not a valid statement.
>Let me know if you still could not reproduce it.

Thank you for looking into it once again..

I have tried with the release mode, but could not reproduce the same. By 
looking at server LOG sent by you “"ANALYZE ng minimal optimizer statistics (1 
target)". ”, seems like some corruption.

So actually looks like two issues here.

1.      Query string sent to server is getting corrupted.

2.      Client is getting crashed.

I will review the code and try to find the same, meanwhile if you can find some 
time to debug this, it will be really helpful.


Reply via email to