Michael Paquier wrote: > Exposing compression and decompression APIs of pglz makes possible its > use by extensions and contrib modules. pglz_decompress contained a call > to elog to emit an error message in case of corrupted data. This function > is changed to return a boolean status to let its callers return an error > instead.
I think pglz_compress belongs into src/common instead. It seems way too high-level for src/port. Isn't a simple boolean return value too simple-minded? Maybe an enum would be more future-proof, as later you might want to add more values, say distinguish between different forms of corruption, or fail due to out of memory, whatever. -- Álvaro Herrera http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Training & Services -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers