On Fri, Mar 20, 2015 at 7:29 PM, Joshua D. Drake <j...@commandprompt.com>

> I am not going to raise a huge stink or anything but it seems rather
> simple.

ALTER SYSTEM  is, if anything, more accessible and easier to do without
reading comments and warnings than config files.

If it were a green field then naming it data_integrity=off would do more to
scare wave people away than hacking the config system. But making the
change now after years seems kind of silly.

I do wonder if it could be made a synonym for setting a large value of
wal_writer_delay. That wouldn't really help Tom's concern about development
but it might provide the same performance for the traditional use case of
initial loading of large databases. That would require a lot of empirical
testing though.


Reply via email to