On Wed, Jun 10, 2015 at 2:41 PM, Michael Paquier <michael.paqu...@gmail.com> wrote: > Hi all, > > While looking at the code of pg_archivecleanup.c, I noticed that there > is some code present to detect if a given string has the format of a > WAL segment file name or of a backup file. > The recent commit 179cdd09 has introduced in xlog_internal.h a set of > macros to facilitate checks of pg_xlog's name format: > IsPartialXLogFileName(), IsXLogFileName() and IsTLHistoryFileName(). > > And by looking at the code, there are some utilities where we could > make use of that, like pg_resetxlog, pg_archivecleanup and pg_standby. > > Attached is a small refactoring patch doing so for HEAD.
Thanks for the patch! I updated the patch as follows. Patch attached. +#define XLogFileNameExtended(fname, tli, log, seg) Move this macro to xlog_internal.h because it's used both in pg_standby and pg_archivecleanup. There seems no need to define it independently. -#define MAXFNAMELEN 64 +#define MAXFNAMELEN 64 Revert this unnecessary change. +/* Length of XLog file name */ +#define XLOG_DATA_FNAME_LEN 24 Shorten the name of this macro variable, to XLOG_FNAME_LEN, for more code readability. Comments? Regards, -- Fujii Masao -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers