On Fri, Nov 6, 2015 at 10:38 PM, Heikki Linnakangas <hlinn...@iki.fi> wrote:
> On 11/06/2015 11:31 PM, Lars Kanis wrote:
>> As a co-maintainer of the PostgreSQL adapter for Ruby, I would like to
>> bridge the new SSL related functions to Ruby methods. However I wonder
>> whether PQsslAttributes() is the best name for the function. Based on
>> this name, I would expect to get key+value pairs instead of only the
>> keys. IMHO PQsslAttributeNames() would express better, what the function
> Hmm, I think you're right.
> The question is, do we want to still change it? It's a new function in
> 9.5, and we're just about to enter beta, so I guess we could, although
> there might already be applications out there using it. If we do want to
> rename it, now is the last chance to do it.
> Thoughts? I'm leaning towards changing it now.
Uh, just to be clear, we been in beta for a month now, beta1 was released
Oct 8. We are not just about to enter it...