On 1/19/2016 10:58 AM, Alvaro Herrera wrote:
Yes, probably something like that. I think it failed the first time because there was a bug (the one I introduced in a967613911f7), then probably changed to src/backend and ran compiles there which probably worked fine, leading to commit fa838b555f90. I might or might not have removed the complete build dir instead of "make distclean"; not sure TBH. As I recall, I tried a couple of builds after I pushed the fix commit and couldn't get them to run at all. But since I saw in buildfarm that other mingw builds were working, I lost interest. Then I deleted the mingw build tree and didn't get back to retrying. TBH the only reason I mingled with mingw at all is that nobody seems interested in fixing Win32 issues, and this patch had been lingering for far too long.

Ok, so your comments here made me think that maybe there is a bug somewhere in the distribution that I was using ( from http://www.postgresql.org/ftp/source/v9.5.0/ ), so I went ahead and cloned the git repo and used the sources from there.

I am happy to announce that I was finally able to build and run PostgreSQL on MinGW-w64, but it only worked with the sources from the git repo, and not with the official downloads from the links above. I'm not sure if there is a bug there that was resolved, or if it is packaged differently, but I was using the official download because I read in several places that it should be easier to build from that distribution as opposed to the git repo.

Thank you for your help,


Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to