Thanks, fixed. The problem was
caused -
there's a postgreSQL came with the
Redhat server, but I tried to install one
only used by a specific user, I set
LD_LIBRARY_PATH in this user's profile.
pg_config --pkglibdir points to the correct
lib dir, but when I run createlang plpgsql template1
it keeps failed.

I've to run -
createlang --pglib=Dir plpgsql template1

createlang -l template1
Procedural languages
  Name   | Trusted?
 plpgsql | t
(1 row)

But here's another observation -
I still can't create plpgsql in the mydb
(createdb mydb) even template1 supports plpgsql.
I've to run
createlang --pglib=Dir --dbname=DB plpgsql.

I guess it's me to make it messy.


> -----Original Message-----
> From: Tom Lane [mailto:[EMAIL PROTECTED]]
> Sent: Friday, January 17, 2003 9:15 AM
> To: John Liu
> Subject: Re: [HACKERS] createlang failed!
> "John Liu" <[EMAIL PROTECTED]> writes:
> > When I run createlang plpgsql template1
> > on linux 7.3 (pg version 7.3.1), it failed -
> > createlang plpgsql template1
> > ERROR:  stat failed on file '$libdir/plpgsql': No such file or directory
> > createlang: language installation failed
> What does 'pg_config --pkglibdir' say?  Is there a in there?
> Is there any additional information about the failure in the
> postmaster's log?  (If you are routing the postmaster's stderr to
> /dev/null, now is a good time to stop doing that --- what I'm wondering
> about is dynamic-linker errors, which will only appear on stderr.)
>                       regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Reply via email to