On Thu, Mar 17, 2016 at 12:04 PM, Tom Lane <t...@sss.pgh.pa.us> wrote:
> David Steele <da...@pgmasters.net> writes:
> > On 3/17/16 11:30 AM, David G. Johnston wrote:
> >> I'd call it "generate_dates(...)" and be done with it.
> >> We would then have:
> >> generate_series()
> >> generate_subscripts()
> >> generate_dates()
> > To me this completely negates the idea of this "just working" which is
> > why it got a +1 from me in the first place. If I have to remember to
> > use a different function name then I'd prefer to just cast on the
> > timestamp version of generate_series().
> Yeah, this point greatly weakens the desirability of this function IMO.
> I've also gone from "don't care" to "-1".
> regards, tom lane
Since that diminishes the already moderate support for this patch, I'll