On Tue, Mar 29, 2016 at 2:45 AM, Alvaro Herrera <alvhe...@2ndquadrant.com> wrote: > Michael Paquier wrote: >> On Wed, Mar 23, 2016 at 12:24 AM, Alvaro Herrera >> <alvhe...@2ndquadrant.com> wrote: >> > Seems reasonable. For the last hunk in your patch, though, I would add >> > a /* translator: */ comment explaining what each of the values is; >> > otherwise it's just incomprehensible percent-sign-salad for the poor >> > translator. Note that if the line is too long you have to use dirty >> > tricks to avoid pgindent from messing it up (see 673b52753489 for >> > example) >> >> OK, done this way. >> >> > I'm not sure if we should keep "blk" in the original or make it a >> > complete word. >> >> OK, a complete word makes more sense. > > Thanks, pushed.
Thanks. > If you're interesting in improving translatability of this program > further, I suggest that messages of this sort > msgid "BKPBLOCK_HAS_DATA set, but no data included at %X/%X" > should have a %s instead of the flag name. I'll think about it. Though I am afraid this would reduce the code readability in xlogreader.c -- Michael -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers