On 2016-04-25 20:53:26 +0200, Fabien COELHO wrote:
> I have just a small naming point:
> /* ereport if segment not present, create in recovery */
> /* return NULL if not present, create in recovery */
> /* return NULL if not present */
> /* create new segments as needed */
> The comments seem pretty clear, but the naming of these options are more
> behavioral than functional somehow (or the reverse?), especially the
> RETURN_NULL and REALLY_RETURN_NULL names seemed pretty contrived to me.
I tend to agree. But "fixing" that would mean changing quite some
additional pieces of code, more than I want to do in a bugfix. I also
think it's not *that* confusing...
Thanks for looking.
Sent via pgsql-hackers mailing list (firstname.lastname@example.org)
To make changes to your subscription: