Hi all,
(folks interested in that in CC)

While looking at some facility in pgcrypto, I have noticed the stanza
created by 56f4478 to prevent conflicts with OpenSSL, like that:
+#define SHA256_Init pg_SHA256_Init
+#define SHA256_Update pg_SHA256_Update

Wouldn't it be better to avoid that, and just rename all those
functions as pg_shaXX_foo? It seems to me that this would be more
in-line with what's already in core. This renaming would be part of
the refactoring effort for SCRAM to have all the functions for SHA1,
SHA156, etc in a unique file sha.c in src/common with a reworked
interface, particularly for SHA1 where things are quite inconsistent
with SHA2XX.

Opinions? As that's a matter really rather independent on SCRAM, I
prefer creating a new thread to gather opinions..


Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to