On 08/27/2016 05:15 PM, Peter Eisentraut wrote:
On 8/26/16 9:26 PM, Andreas Karlsson wrote:
I have attached a patch which removes the < 0.9.8 compatibility code.
Should we also add a version check to configure? We do not have any such
check currently.

I think that is not necessary.

I was going to change the configure test to check for a different function that we use, that's only present in 0.9.8 and later. But the only such functions were related to ECDH, and the use of those functions is inside "#ifndef OPENSSL_NO_ECDH", so they're not suitable for the autoconf test. So I gave up. If you try to build with 0.9.7, you'll get compilation errors because of those ECDH symbols, and with 0.9.6, probably on some other symbols.

Pushed with some small doc fixes, thanks Andreas! I'll continue reviewing the rest of the patches.

- Heikki

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to